Returns Processing Issue

Incident Report for Health Recovery Solutions

Resolved

As of 9:59 AM EDT, the issue preventing users from submitting return orders through the Inventory Management Portal has been resolved. Returns can now be created without errors. Thank you for your patience while we worked to restore functionality.
Posted Jun 26, 2025 - 09:59 EDT

Update

The issue preventing users from submitting return orders through the Inventory Management Portal has been resolved. Returns can now be created without errors. Thank you for your patience while we worked to restore functionality.
Posted Jun 26, 2025 - 09:58 EDT

Investigating

At this time, users are unable to submit return orders through the Inventory Management Portal. Attempting to do so will result in an error message. Please note that new order submissions continue to function as expected—this issue is limited to return orders only.
Posted Jun 26, 2025 - 09:43 EDT
This incident affected: OMS (OMS).