Cellular Peripheral Data Not Transmitting to Clinician Connect

Incident Report for Health Recovery Solutions

Resolved

This incident has been resolved.
Posted May 15, 2025 - 11:59 EDT

Identified

We are currently investigating an issue where metrics from cellular peripherals are not transmitting to Clinician Connect. This issue is limited to a very small number of clients who use cellular-enabled peripheral devices. We are actively working to identify the root cause and will provide updates as more information becomes available.
Posted May 15, 2025 - 09:10 EDT
This incident affected: ClinicianConnect Web.